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Chapter 1

Introduction

Dr. Genius is the interactive geometry package for the Gnome Desktop. It allows
users to create geometric figures that can be manipulated with respect to geometric
rules. The program is useable with students from the primary through secondary
levels.

Figure 1.1: DR. GEOwelcome screen
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To create a new empty geometric figure, the user clicks on the first (on the left)
button in the toolbar. Alternatively, a new figure can be created using the menu
item File->New->Figure from the menu bar. When a new figure is created, a new
toolbar with a set of six icons appears. The last item (on the right) in the toolbar
is an option menu; it is used to adjust the scale of the current geometric figure.

The six icons correspond to different types of functions. These functions are
described in the next chapter.

With each figure, a pane is available. By default the pane is pushed to the
extreme left so that only the representation of the figure is visible. At any moment,
the user can push the pane to the right to make visible the figure description. A
figure description is a tree list. The tree is composed of all the elements of the figure.
The elements relative to other elements can be expanded by pressing the 4’ sign,
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Figure 1.2: An empty geometric figure
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Figure 1.3: A Dr. GEOfigure and its description
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that way the user can visualize the parents of this element.



Chapter 2

Basic Functions

This chapter describes the tools used to construct geometric figure. At the end of
this chapter, customisation is presented.

2.1 Construction Tools

These tools are split into six groups available from the second toolbar of DRr. GEO.

Figure 2.1: DR. GEO’s tool categories and their descriptions
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2.1.1 Point Tools

Free Point

%

Create a free point on an area or a free point on an uni-dimensional object. In
the first case, the created point can be moved anywhere in the figure area. To build
the point the user just clicks on the background. In the latter case, it is constrained
to the uni-dimensional object (line); it is stuck to the object. To build this kind of
point the user clicks over a line (i.e. straight line, ray, segment, circle, arc, etc.).

7



8 CHAPTER 2. BASIC FUNCTIONS

Midpoint

Create the middle of two points or the middle of a segment. In the first case,
the user selects two points. In the latter case the user just selects a segment.

Intersection

Create the intersection point(s) of two line objects. The user needs to select two
line objects.

Point by its Coordinates

It

Create a point defined by its coordinates. The user needs to select two numbers,
the first selected number is the abscissa; the second one is the ordinate.

2.1.2 Line Tools
Straight Line

Create a straight line defined by two points. The user selects two points.

Ray

Create a ray (half-line) defined by two points. The user selects two points; the
first point is the origin, the second one belongs to the ray.

Segment

Create a segment given by two points.

Vector

Create a vector given by two points. The user selects two points. The first point
is the origin; the second one is the extremity.
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Circle

0

Create a circle. The user can create a circle from different selections:
1. the centre and a point on the circle;
2. the centre and a number (the radius of the circle);

3. the centre and a segment which length is the radius of the circle.

Arc Circle

o
Create an arc defined by three points. The first selected point is the origin of

the arc; the third one is the extremity and the second one is a point on the arc.

Locus

BS

Create a locus defined by two points. The user selects two points, one is a free
point on a line and the other one is a constrained point of the first one (i.e. when
one moves, the other one does as well).

Polygon

Create a polygon defined by n points. The user selects n+1 points delimiting
the polygon. The first and last selected points are the same; this tells DR. GEOthat
the selection is over. The polygon object is not an object like the other lines; it is
not possible to place a point on it or to construct an intersection between a polygon
and another line object.

2.1.3 Transformation Tools

Parallel Line

Create a line passing through a point and parallel to a ”direction” (another line
or line segment moving in a ”direction”). The user selects a point and a direction
(i.e. a straight line, a ray, a segment or a vector).
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Perpendicular Line

Create a line perpendicular to a direction and passing through a point. The user
selects a point and a direction (i.e. straight line, a ray, a segment or a vector).

Axial symmetry

Create the image of an object by an axial symmetry. The user selects an object
to transform and the axis of symmetry (a straight line). When the user wants to
construct the image of a straight line, s/he must first select it with the mouse; the
first selected line is the line that which will be transformed.

Central Symmetry
o

Create the image of an object by a central symmetry. The user selects the
object to transform and the centre of its symmetry (a point). When the user wants
to construct the image of a point, s/he must first select it (with the mouse). The
transformation will then be performed on this point.

Translation

Create the image of an object by translation. The user selects the object to
transform and the vector of translation. When the user wants to construct the
image of a vector, s/he must select it (with the mouse). The transformation will
then be performed on this vector.

Rotation

Create the image of an object by a rotation. The user selects the point to
transform, the centre and the angle of the rotation. When the user wants to create
the image of a point, s/he must first select it (with the mouse). The transformation
will then be performed on this selected point.

The angle can be selected from different type of value:

e numeric value: in this case the angle is expressed in radians. Examples of
numeric values are: free value, distance between two points, a segment length,
a coordinate, a value returned by a Dr. Genius Guile Script, etc.;



2.1. CONSTRUCTION TOOLS 11

e a geometric angle formed by three points: in this case the angle is
expressed in degrees. Be aware that in this case the angle can only fall within
05 180);

e an oriented angle formed by two vectors: in this case the angle is ex-

pressed in degrees between [0 ; 360].

Scale

ﬁ%

Create the image of a an object by a scale transformation (homothetie). The user
selects the point to transform, the centre and the factor (i.e. a number). When the
user wants to create an image of a point, s/he must first select it; the transformation
will be performed on this selected point.

2.1.4 Numeric Tools

Distance, Length & Number

r numeric value. numeric valu n mpu r user- edi
Create a eric value. The eric value can be co ted or user- edited
depending on the user’s selections:

1. two points: distance between these two points;

2. a segment: the length of this segment;

3. a vector: the vector’s magnitude;

4. a circle: the length of the circle;

5. an arc circle: the length of the arc;

6. a straight line: the slope of the line;

7. a straight line and a point: the distance between the line and the point;

8. a click on the background permits the user to enter a new value (i.e. a free
value).

Angle

Create an angle defined by three point or two vectors. In the first case, the
resulting angle is non oriented (i.e. a geometric angle in the range [0 ; 180]. In the
second case, the angle is oriented and it is within the range ]-180 ; 180].
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Coordinates

Create the coordinates of a point or a vector. This tool creates both the abscissa
and the coordinate.

Dr. GeoGuile Script

Create a DR. GEOGuile Script. The script receives input of n objects. It even-
tually returns a number, printed in the figure. A script can be used for its side
effects or for its returned value. The DR. GEOGuile Scripts are covered in details
in the Chapter Advanced Features Chapter [3| and exactly at Section Script Section

B2 page 23

2.1.5 Macro-Construction Tools

Setting a Macro-Construction

Extract a construction sequence of a figure and turn it as a macro-construction.

Executing a Macro-Construction

=

Execute (i.e. “run” or “play”) a pre-built macro-construction. The macro-
construction can be either newly created or loaded from file.

(') Macro-Constructions are exposed in Section Macro-
ConstructionSection [3.T}, page [T9}

2.2 Other functions

2.2.1 Moving figure
Figure can be moved by pressing CONTROL key and button 1 of the mouse.

2.2.2 Moving object

Ny
(g\

An object can be moved by draggin it. The figure is then recomputed according
to its properties. Almost every type of geometric object can be moved. When
necessary, DR. GEOperforms a reverse dragging. For example, this occurs when the
user moves a line defined by two points, DR. GEOwill move the two points according
to the desired line position.
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2.2.3 Deleting Objects

An object on the figure can be deleted when activating this menu. Eventually,
the user can undelete using the undo function from the toolbar or application menu.
By default the undo level is set to 10 but the user can adjust this value from the
preference dialog.

2.2.4 Editing Object Styles

B

Fach object owns such style attributes as colour, thickness, label, size or shape.
Additionally, it is possible to hide an object temporarily without deleting it. For
example, it can be useful to hide intermediate constructions without deleting them.
All these attributes can be adjusted from a dialog activated when the user selects
an object in the figure.

The point style dialog concerns any kind of point object. From it, it is possible
to adjust its color, shape, size, name and visibility.

Figure 2.2: The style dialog for point object
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The line style dialog concerns straight line, ray, segment, vector, circle, arc circle,
locus. From it, it is possible to adjust the color, style, name and visibility.

The numeric & polygon style dialog concerns all kind of values (user edited,
computed by user’s DR. GEOGuile Script or representing geometric measure) and
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Figure 2.3: The style dialog for line object
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Figure 2.4: The style dialog for numeric & polygon objects
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2.2.5 Editing Object Properties

Some objects own properties adjustable by the user. When the user clicks
on such objects, an appropriate dialog appears. Actually the following objects own
user adjustable properties:

1. Free point on the area: abscissa and coordinate can be edited;

2. Free value: its value can be edited;
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Figure 2.5: Edit free point coordinates
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Figure 2.6: Edit free value
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3. Script: its code can be edited.

Figure 2.7: Edit a script
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2.3 User’s Preferences

2.3.1 Default Behaviour

DRr. GEodefault behaviour can be customised in several ways. To adjust the pref-
erences, the user goes to the menu item Edit->Preferences... to open the pref-
erences dialog.

The dialog is composed of a notebook with two pages:

1. The first page concerns global preferences:

Actually, the user can only adjust the default name of a session to be saved
on disk.

2. The second page is about geometric figure preferences:
From this page, a wide range of option can be adjusted:

e The number of Undo/Redo level;
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Figure 2.8: Global preferences
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Figure 2.9: Geometric figure preferences
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e The default figure name to be used when a new figure is created. The
%d is replaced by an integer value handled by DR. GEO, this value is
incremented at each newly created figure;

e Several default name for single figure file and LaTeX /PostScript export;

e In the superior area of the page, another notebook allows the user to
adjust the default object style of each figure item (geometric or numeric
ones). The concerned styles are colour, shape, size and style.
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2.3.2 Other Preferences

In addition to changing the default behaviour of DR. GEO, the user can change the
name of a figure from the menu item Edit->Rename.

Figure 2.10: Renaming a figure view
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Chapter 3

Advanced Features

In this chapter we present features used to extend the cabilities of DR. GEOin various
ways.

The first is macro-construction; it allows the extraction of a construction logic
in a record. Then, this record can be repeated or saved as a file.

The Dr. GEOGuile Script features are the other means for extending DR. GEO.
These scripts are really figure items like the other geometric items. They receive
as input, user selected figure item references and they return values, plugged into
figures.

DRr. GEOGuile Scripts can be useful for their returned values or their side effects;
which really depends on what the user wants to achieve.

The last feature is user-interface customisability. The idea is to give the teacher
the cability to prepare geometric figure files with tools taken from the Dr. Genius
toolbar and contextual menu. This capability may help in achieving a desired “ped-
agogical effect”

3.1 Macro-Construction

Macro-constructions are a bit like a procedure which receives as input figure items
and then returns one or more figure items, constructed by the macro-construction.
They are built on a model defined by the user. This means that the user has to build
a construction sequence only once. Then she can tell DR. GEOthat she wants this
sequence to be recorded in a macro-construction. To record a construction sequence,
Dr. GEOneeds to know which are the initial items of the sequence and the resulting
items. Of course the resulting items must depend only on the initial items; otherwise
Dr. Genius would not be able to deduce the resulting items from the initial ones.
Using its knowledge of the initial and resulting items, DR. GEoOdeduces the
construction sequence and saves it in a macro-construction. The user can then
execute this macro-construction simply by inputting (initial) items (they must match
the type) in the figure. The macro-construction can then build the resulting items.

(') Invisible intermediate figure items are also built by the
macro-construction. These items are necessary to build the
resulting items.

19
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To illustrate the macro-construction feature, we will use an example in which
the user wants to record the construction of a circle with a given center which passes
through three points, also given.

Figure 3.1: Our initial figure

A

Before constructing the macro-construction, the user needs to construct the final
figure; it is used as a pattern from which to build the macro-construction.

Figure 3.2: Our figure with the resulting construction

3.1.1 Constructing a Macro-Construction

At this point, the construction sequence is done. Now, the user needs to tell Dr. Ge-

nius that she wants to create a macro-construction from this sequence. She can call
T A

the Construct a macro function from the icon or from the contextual menu
in the figure view.

From the wizard dialog, the user selects the input & output parameters, the
name and description of the macro-construction.

The second page of the dialog is used to select the input parameters. In our
example, these are the three initial points. The user just needs to go to this second
page and she can select the three points in the figure. The selected items will blink.

From the 3rd page, she selects the output parameters. In our example, we want
the circle and its centre as the result of the macro-construction. She proceeds as in
the case of the input parameters to select them.

In the 4th page, the user enters the name and the description of the macro-
construction. This information is displayed when the user executes a macro-
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Figure 3.3: The 1st page of the wizard dialog to construct a macro-construction
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1. First select the input parameters,
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Figure 3.4: The 2nd page, the three points are already selected
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Figure 3.5: The 3rd page, the circle and its centre are already selected
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construction, so it helps to distinguish macro-construction between them.

From the last page of the wizard dialog (the 5th one), the user can terminate the

creation by pressing the Finish button. Alternatively, she can return to previous
pages to adjust the macro-construction parameters.
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Figure 3.6: The 4th page, the name and description of the macro-construction
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(') If the input & output parameters selections do not match
(DRr. GEOcannot extract the logic of the construction), the
macro-construction cannot be built. In such a case, the
user needs to reconsider the input and output parameters
selection. She can go back to the 2nd and 3rd page of the
wizard dialog to adjust her choices.

At this point the macro-construction is built and recorded in DR. GEO. In the
next section, we will see how to use this macro-construction.

3.1.2 Executing a Macro-Construction

To execute a macro-construction, the user calls the Execute pre-build macro func-
=

tion from the icon or from the contextual menu in the figure view.

From the wizard dialog, the user selects the macro-construction. In the 2nd page,
she selects the macro-construction from the list in the top area of the dialog. Once
a macro-construction is selected, she can directly click on the input parameters in
the figure. As soon as all the necessary input parameters are selected, the macro-
construction is executed and the final parameters appear.

Figure 3.7: The user selects the input parameters directly in the figure

. . =
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In our example, the macro-construction needs three input parameters (three
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points) and it builds a point and a circle. To execute our macro-construction, we
need a figure with a least three points.

Figure 3.8: A figure with three points

Once our macro-construction is applied to these three points, we get the desired
circle and its centre.

Figure 3.9: The resulting figure with the circle and its centre

3.2 Dr. GeoGuile Script

DRr. GEOis Guile aware. This means it is possible to execute Guile scripts within
Dr. GEO. But what is Guile? From the Guile manual:

Guile is an interpreter for the Scheme programming language, packaged
for use in a wide variety of environments.

The following citation describes accurately how is used Guile within DR. GEO:

Like a shell, Guile can run interactively, reading expressions from the
user, evaluating them, and displaying the results, or as a script inter-
preter, reading and executing Scheme code from a file. However, Guile
is also packaged as an object library, allowing other applications to eas-
ily incorporate a complete Scheme interpreter. An application can use
Guile as an extension language, a clean and powerful configuration lan-
guage, or as multi-purpose ”glue”, connecting primitives provided by the
application.
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In DRrR. GEO, an API is available from the Guile interpretor. This API is a set of
hooks in the geometric engine. Therefore the user can write scripts to manipulate
figure items (geometric and numeric). Also, as scripts are figure items like any other,
they do not need to be saved as separate files. They are saved in the figure file. In
the following, we will use the DGS acronym for DR. GEOGuile Script.

3.2.1 Creating a DGS
3.2.2 More about DGS

3.3 User interface customisation
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Saving and Loading
Constructions

Constructions can be saved in two ways. One construction per file or a construction
set per file (i.e. a Dr. Genius session).

4.1 Saving one construction

From the menu File->Save or File->Save As..., a file can be saved containing
the figure under the active view.

(') Dr. Genius can work with several figures at the same time.
The user can switch from one figure to another one by click-
ing on the corresponding tabs.

With the second menu, the user can change the name of the saved document.

(') The default file name proposed to the user by Dr. Genius
can be changed from the Edit->Preferences... menu.
For more information see Section Defaut BehaviourSection

P31} page [T5]

4.2 Saving a Session

A session is a set of Dr. Genius data the user wants to save in one shot in a file.
It allows teacher to organise a set of data (figure, macro-construction, note) in one
file, so it is more convenient to re-open such data.
From the File->Save Multiple menu, the user can display the session dialog.
The list of all active data is saved in this file and presented in a table. The first
colon represents the type of data contained in Dr. Genius. The second one represents
the name of the data.

(') Actually, a session can contain three kinds of data: 2D in-
teractive figure, macro-construction and text.

Then users can decide to select one by one the data to save from the list. Then
she can press the Save Session button. Alternatively, she can save all the data by
pressing the Save All button.

25
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Figure 4.1: The Dr. Genius session dialog
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(') File->Save Multiple menu is the only way to save macro-

constrcutions to a file.

4.3 Loading Constructions
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Cook Book
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